ie7-js, un javascript qui rend IE plus standard !

Par j0k le mercredi 09 janvier 2008, 11:28 dans développement - 9281 vues

On a beau se réjouir des futures versions d'Internet Explorer mais à chaque fois c'est pareil, on est déçu au niveau du support des standards lors de sa sortie officielle. Quoi que, IE8 passerai le test Acid 2, une bonne chose, à voir...
Cependant, les anciennes version d'IE sont toujours là (et ceux pour un bon moment ...) et elles ne supportent pas tous les standards (ça c'est pas une nouveauté ...). C'est ici qu'intervient ie7-js, un petit outil JavaScript qui rend IE presque comme un navigateur respectant les standards ! Si si, vous avez bien lu, "IE" et "standard" dans la même phrase sans négation entre les deux :-)

Cet outil est composé de deux scripts JavaScript :

  • IE7.js, qui permet de mettre à niveau IE 5/6 par rapport à IE7
  • IE8.js, qui s'applique à toutes les versions d'IE pour apporter un meilleur support CSS

A noter que la transparence des PNG sera supporté par IE5 et 6 en utilisant ce script. Vous pouvez tester le rendu de ces scripts directement sur le site officiel.

7 commentaires en tout !

1. j0k le jeudi 10 janvier 2008, 11:45 #permalien
j0k

Je n'ai pas encore eu le temps de le tester ... Dis moi ce que t'en pense quand tu l'aura testé ;-)

2. KrazyThug le jeudi 10 janvier 2008, 12:18 #permalien
KrazyThug

Fort interessant !
Tu as pu le tester ?

Par contre, il faut évidement que le Javascript soit activé sur le navigateur de l'internaute mais bon, pour le peu de gens qui le desactive.

Merci de cette trouvaille ;)

3. Oyo le lundi 14 janvier 2008, 02:10 #permalien
Oyo

Ah je testerais ça au buro vu qu'il tourne tous sous IE -_-'

4. ff le lundi 14 janvier 2008, 10:31 #permalien
ff

j0k3r_n0ir : > A noter que la transparence des PNG sera supporté par IE5 et 6 en utilisant ce script.

J'ai testé plus que 5 scripts qui permet de forcer les extension PNG, mais aucun résultat efficace. Je vais tester celui là, et si ça fonctionne je vous mets au courant.

Merci Jocker!! :o) :o) :o) :o) :o) :o) :o) :o)

5. Oyo le vendredi 18 janvier 2008, 05:24 #permalien
Oyo

Salut,
Il semble qu'il y est une imconpatibilité avec Prototype ou Scriptaculous Pas eu vraiment le temps de le tester plus

6. j0k le vendredi 01 février 2008, 07:30 #permalien
j0k

C'est apparemment une erreur connue et elle sera fixé dans la prochaine release ;-)
http://dean.edwards.name/weblog/2008/01/ie7-2/#comment178089 (puis un peu plus bas) http://code.google.com/p/ie7-js/issues/detail?id=6

7. Oyo le vendredi 08 février 2008, 03:52 #permalien
Oyo

J'avoue ne pas avoir regarder plus avant ^^

Pensez à vous inscrire !

  • C'est rapide
  • Utiliser votre compte Facebook
  • Ou votre Open ID
Laisser un commentaire





Catégories


Tags


Liens